PCB assembly discussion


Instructions and discussion for constructors of our nixie button kit

Site Admin

Posts: 950

Joined: Tue Jul 24, 2012 8:05 pm

Post Sun Apr 19, 2015 7:28 pm

PCB assembly discussion

Suggestions for improvements, mistakes, hints here please.

Site Admin

Posts: 950

Joined: Tue Jul 24, 2012 8:05 pm

Post Tue Feb 07, 2017 7:10 pm

Re: PCB assembly discussion

The .hex file for a PIC10f320 if you need to program a replacement:
Attachments
Button piccode.rar
(258 Bytes) Downloaded 565 times

Posts: 6

Joined: Thu Aug 10, 2017 1:10 am

Post Sun Aug 27, 2017 5:09 am

Re: PCB assembly discussion

For the life of me, I can't get the switch to "click" or the output to read @ 5v when I touch the Nixie tube. Any suggestions on what to check?

Site Admin

Posts: 950

Joined: Tue Jul 24, 2012 8:05 pm

Post Wed Aug 30, 2017 3:14 am

Re: PCB assembly discussion

Sometimes they can be too sensitive and remain 'on' which won't trigger the relay. Check the voltage on the gate of T2 and if it's high, try adding a 5k6 resisor across R4. If that doesn't help reverse the primary connections on L1.

The relay requires 24V which is generated by L1's primary via D2/R1, this slowly charges C1. When it's triggered C1 is discharged through the relay coil causing a short 'on' pulse. if the relay is constantly switched on by T2 the capacitor won't charge and nothing happens.

Posts: 6

Joined: Thu Aug 10, 2017 1:10 am

Post Wed Sep 06, 2017 6:49 pm

Re: PCB assembly discussion

Sorry for the ignorance, but what voltage should I be looking for? What should it be/ what would be considered too high? What contacts am I going to check when I "check it at the gate"?

Site Admin

Posts: 950

Joined: Tue Jul 24, 2012 8:05 pm

Post Fri Sep 08, 2017 5:36 pm

Re: PCB assembly discussion

It's the middle pin of T2, measure the voltage from there to ground. If it's not 0V it will be on and you'll need to add a 5k6 resistor across the 3k3 already fitted. Another thing to watch out for is if you're testing it before building it into the case and the nixie is lying on its side, contact with the table or work surface under the tube may cause it to be triggered.

Posts: 11

Joined: Tue Nov 07, 2017 9:56 pm

Post Tue Nov 14, 2017 7:35 pm

Re: PCB assembly discussion

Just a quick instructions bug report:
You have the colour code description for the 12k resistor wrong on the third post down on this page: viewtopic.php?f=16&t=92
Also you don't actually say to fit the pic anywhere, as far as I can tell. It's sort of implied that it could be fitted before first power on because two pins get blobbed across "to protect the pic", but nothing definite to reassure the builder :)

Cheers,
Robin.

Site Admin

Posts: 950

Joined: Tue Jul 24, 2012 8:05 pm

Post Wed Nov 15, 2017 4:17 am

Re: PCB assembly discussion

Those instructions have been up for over two and a half years and nobody else noticed... Fixed.

Thank you :)

Posts: 47

Joined: Sat Apr 11, 2020 2:45 pm

Post Sun Jun 07, 2020 5:19 pm

Re: PCB assembly discussion

Tony wrote:If you intend to use the relay now is the time to fit this, remeber to remove that solder bridge across C6 or it won't switch:

A black "Rayex Elec LEG-24" relay https://www.tme.eu/Document/311affc211749c2a4c93ad074af62b72/LEG-SERIES.pdf was supplied which does not fit the PCB (due to a very different pin-out); nor can I find instructions on how to make it fit. (The nixie glows satisfyingly.) In an attempt to try get it working I have now almost certainly killed the relay. I cannot find the one in the pictures to buy? From where can it be sourced?
Last edited by jmmcg on Sun Jun 07, 2020 5:23 pm, edited 1 time in total.

Posts: 47

Joined: Sat Apr 11, 2020 2:45 pm

Post Sun Jun 07, 2020 5:23 pm

Re: PCB assembly discussion

Tony wrote:Fit the 3K3 resistor (Orange Orange Red). Fit this in the location marked for R4 as shown:

I seem to have a 2k2 resistor for this (red red red gold). Not the 3k3 as noted. I note elsewhere in your instructions that if the relay is not sensitive enough, this value should be increased. I have no 3k3s or higher sadly to test this. What do you think?

I get 0V at the base of T2 but about 36V across C1. Clearly something is wrong...

(Checked for bridges,etc.)

In fact none of the resistors match!
1K2 resistor (Brown Red Red). Fit this in the location marked for R3 as shown:
I have a brown-black-red-gold 0k2...

Fit the 12K resistor (Brown Red Black Brown). Fit this in the location marked for R1 as shown:
I have a brown-red-black-red 12k. Note that Brown Red Black Brown I read as 1k2...

For the capacitors:
Next the 10n or 33n capacitors (brown discs).
They are marked 333 (I assume this is ok from the instructions for the cylinder clock).

Can you clarify if these components are correct?

I tried swapping the L1 primary coil leads to no avail. The voltage across the actuator for the relay is about 0.9V (nixie touched by hand) dropping to 0.6V (nixie left in free air).
Last edited by jmmcg on Sun Jun 07, 2020 8:33 pm, edited 3 times in total.
Next

Return to Plasma button of Doooom

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software