Piece display PCB discussion


Assembly instructions for the V1 chessboard.

Posts: 12

Joined: Wed Sep 19, 2012 5:28 am

Location: Pittsburgh, PA USA

Post Sun Feb 17, 2013 3:04 am

Re: Piece display PCB discussion

---- Coating the Nixie Tube with Clear Acrylic ???

Do the tubes get very warm? Probably not since we play with them...

I was thinking to spray several coats of a clear Acrylic or other to protect the tubes in case they get dropped. Do you think this would work?

Site Admin

Posts: 933

Joined: Tue Jul 24, 2012 8:05 pm

Post Wed Feb 20, 2013 7:48 pm

Re: Piece display PCB discussion

I'm not sure it would add enough cushioning to protect the tube. They're quite strong so any force that would break it probably wouldn't be reduced much by a few coats of varnish. It would stop flying glass everywhere though.
If you want drop protection how about making a brass wire 'roll bar cage' for each piece?.

On the heat subject, they're dissipating less than half a watt each including heat conducted from the board coil.

Posts: 24

Joined: Tue Jan 15, 2013 2:01 am

Post Tue Mar 26, 2013 6:15 am

Re: Piece display PCB discussion

So, I hit my first display PCB problem. I have a completed piece that won't light. I've finished just about 24 of the 32 display boards and this is the first one to give me any problems...

I checked all the solder points and everything looks nice. The diode is pointing the correct direction. Not sure what else to do so I checked the voltage at the nixie tube connector sockets and compared to a working board. The working board shows ~145v but the non-working board only shows ~35v (so no wonder it's not working). I also checked the voltage from the positive side of the coil to ground on the display board (not sure if this even makes sense as a test, but again, didn't know what else to do). On DC it showed zero volts, but on AC it showed 4v for the working and 0.4v for the non-working. Does any of that make sense?

Any troubleshooting would be much appreciated!

Thanks,
Sean

Site Admin

Posts: 933

Joined: Tue Jul 24, 2012 8:05 pm

Post Tue Mar 26, 2013 5:00 pm

Re: Piece display PCB discussion

There's a short somewhere, check for solder bridges across the ceramic capacitors and if it's an engraved board look for copper whiskers/dust between tracks. If there's nothing obvious check the voltage at each capacitor and see where it doesn't increase.

Posts: 12

Joined: Wed Sep 19, 2012 5:28 am

Location: Pittsburgh, PA USA

Post Tue Mar 26, 2013 8:36 pm

Re: Piece display PCB discussion

Tony wrote:..... If you want drop protection how about making a brass wire 'roll bar cage' for each piece?.




Now Tony! Great Idea - :idea:

That would be a very cool look! Brass, Copper, Stainless, Silver, or any type of metal wire 'roll cage' would bump the Geek Cool Meter WAY UP! The steam punky 'roll cage' could be shaped to indicate the piece power - Kings would be Kings, Knights would be Knights. Great Idea!

:D

Site Admin

Posts: 933

Joined: Tue Jul 24, 2012 8:05 pm

Post Wed Mar 27, 2013 3:23 am

Re: Piece display PCB discussion

I'd like to see it done but it would need a lot of patience and time. There should be about 8mm depth to drill into around the edge of the piece so it is doable.

Posts: 24

Joined: Tue Jan 15, 2013 2:01 am

Post Thu Apr 04, 2013 12:33 am

Re: Piece display PCB discussion

Sorry for not getting back sooner. Work has me pretty bogged at the moment, but I was able to squeeze in a little project time this past weekend.

Tony wrote:There's a short somewhere, check for solder bridges across the ceramic capacitors and if it's an engraved board look for copper whiskers/dust between tracks. If there's nothing obvious check the voltage at each capacitor and see where it doesn't increase.


I gave the board a very thorough inspection and didn't find any obvious bridges. To do the voltage test I first sketched out a very rough schematic of the circuit. Forgive my not using the proper symbols (hey, cut me some slack, I'm a CPA not an electrical engineer! :D ). The voltage measurements in parenthesis are for the bad board and the measurements without parenthesis are from a working board. It looks like to me the voltages are stepping up like they should, just they are starting out much too low. Do you think I have a bad component or maybe the wires in the coil got shorted somehow?
Attachments
voltage schematic.JPG
voltage schematic
voltage schematic.JPG (209.19 KiB) Viewed 18895 times

Site Admin

Posts: 933

Joined: Tue Jul 24, 2012 8:05 pm

Post Fri Apr 05, 2013 12:14 am

Re: Piece display PCB discussion

Usually I'd say a short at the output but there doesn't seem to be any voltage 'droop' so it may be near the input. Easy things first, try another nixie if you haven't already, make sure the glass diode is the right way round and the 10n tuning capacitor is connected across the winding. Could you post a photo of the PCB?.

Posts: 24

Joined: Tue Jan 15, 2013 2:01 am

Post Sat Apr 06, 2013 12:03 am

Re: Piece display PCB discussion

Yeah, I've tried a few nixie's. I've even swapped out from working boards and none work.

Here's a few pics
bad display 1.JPG
bad display 1.JPG (248.64 KiB) Viewed 18872 times

bad display 2.JPG
bad display 2.JPG (253.81 KiB) Viewed 18872 times


The diode is correct and the 10n is connected.

Site Admin

Posts: 933

Joined: Tue Jul 24, 2012 8:05 pm

Post Sat Apr 06, 2013 7:17 pm

Re: Piece display PCB discussion

Check the track running round the bottom edge of the board in pic1, from the coil to the SMD capacitor hasn't been cut when the board was routed, after that it's component faultfinding. Try removing the second diode pack and see if the voltages on the first one go up, that should give a clue as to where in the chain the fault is.
PreviousNext

Return to Assembly instructions

Who is online

Users browsing this forum: No registered users and 2 guests

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software